
 

Terrain and Imagery Tutorial 

By: Brian Zager 

http://www.zagerdesign.com/golf_design/ 

This tutorial provides and overview on how terrain data and overhead imagery are used to 

create real courses or courses based on real locations. It explains how to download the 

highest resolution imagery and terrain data from different sources and it details how to 

use them with CPG2. If you have any questions about anything within this tutorial feel 

free to ask in the forum. 
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DEM Overview 

A Digital Elevation Model (DEM) is a digital representation of real world terrain. DEM 

files are used to generate plot wide elevations in the game. This is useful for doing real 

course renditions or fictional courses based on real locations. 

DEM QUALITY  

How accurate a DEM is depends on its resolution. It is similar to the resolution of an 

image in that a higher resolution produces sharper detail. Think of the DEM as a grid of 

measured elevation points. The resolution is measured by how far apart these points are. 

In a 30 meter (1 arc second) resolution DEM each point on the grid is separated by 30 

meters. A 10 meter (1/3 arc second) DEM is a higher resolution because there is only 10 

meters between each point on the grid. There is also vertical resolution which indicates to 

what decimal place elevation measurements are accurate. 

Most DEMs are 30 meter (1 arc second) or 10 meter (1/3 arc second) resolution with 0.1 

meter vertical resolution. With these resolutions you get good plot scale elevations but it 

does not do everything for you. You still have to do the fine detail work like green 

contours, mounding, bunker shaping, etc. If you're lucky enough to have a 1 meter (1/9 

arc second) DEM you may not have to do as much of this fine detail work. Resolutions 

worse then 30 meter (1 arc second) are not very useful unless your area has extreme 

elevation changes. 

DEM DOWNLOADS 

Below is a list of sources you can download DEMs from: 

 USGS Seamless - Coverage of the entire US in 30 meter resolution and ~ 70% of 

the US in 10 meter resolution (excluding Alaska which only has 60 meter 

resolution).  

 GeoComm - The same data used by the USGS Seamless server but presented in a 

different form.  

 GeoBase - DEM Coverage of Canada.  

 NetGIS - DEM coverage of Europe.  

This tutorial goes into detail on downloading from the following sources: 

 USGS Seamless  

 GeoComm  

http://seamless.usgs.gov/
http://data.geocomm.com/dem/demdownload.html
http://www.geobase.ca/
http://netgis.geo.uw.edu.pl/srtm/Europe/


 

Imagery Overview 

Using satellite and other aerial imagery as a transparency over your plot allows you to 

accurately trace fairways, greens, tees, water, etc. and place objects in the correct location 

on your plot.  

IMAGE QUALITY  

Generally a higher resolution image makes it easier to layout your course. This tutorial 

explains how to get the highest resolution image from your source. It's not the only factor 

though. Shadows, the season an image was taken in, how old an image is, etc. can make 

different parts of your image difficult to use or inaccurate. Because of this it is better to 

use multiple images if they are available for your location. 

IMAGERY DOWNLOADS 

Below is a list of sources you can download imagery from: 

 Google Earth/Maps - High resolution color imagery around the world. No 

complete coverage of any specific area.  

 Microsoft Virtual Earth - High resolution color imagery around the world. 

Complete coverage of the US.  

 USGS Seamless - Black and white imagery and topographic maps covering the 

entire US. Color Imagery in some areas.  

 TerraServer - Most of the same imagery available from USGS Seamless.  

This tutorial goes into detail on downloading from the following sources: 

 Google Earth/Maps and Microsoft Virtual Earth  

 USGS Seamless  

http://earth.google.com/
http://maps.google.com/
http://www.microsoft.com/virtualearth/
http://seamless.usgs.gov/
http://terraserver-usa.com/


 

Location Coordinates 

Before you begin you need to find the latitude and longitude coordinates for some points 

around your location: 

 Northwest corner of the plot.  

 Southeast corner of the plot.  

 Approximate center of the plot.  

The easiest way to do this is with Google Earth. If you do not already have it, download 

and install it before proceeding.  

1. Open up Google Earth.  

2. Go to Tools > Options.  

3. Under Show Lat/Long change "Degrees, Minutes, Seconds" to "Degrees" and 

click OK. This gives the coordinates in decimal degrees. 

 
4. Find the location you want to use. You can do this by panning and zooming the 

image or by entering a city/address in the "Fly to" field in the upper left.  

5. Once you have your location in view double click the N on the compass in the 

upper right. This rotates the image to ensure north is facing up.  

6. Move your mouse to the point you want to use as the northwest corner of your 

plot. Give plenty of room for the north and west boundaries of your course. If 

there are land features visible outside the course you may want to include these 

too.  

7. Write down the latitude and longitude shown in the lower left portion of the 

screen including any negative signs. Negative latitude indicates the Southern 

Hemisphere and negative longitude indicates the Western Hemisphere. 

 
8. Repeat steps 6 and 7 for southeast corner and the approximate center of the plot. 

http://earth.google.com/


 

USGS Seamless Data Distribution System 

The USGS has a site called the Seamless Data Distribution System. This site makes it 

easy to download USGS data. 

1. Go to the USGS Seamless Site and choose either US or International data. From 

here the site takes a few moments to launch.  

2. A map with a set of buttons to the left opens. You can use the map to zoom in to 

your location but it is slow. Instead it is easier to just enter the coordinates. Under 

Downloads on the left side, click on Define Area by Coordinates. 

 
3. A new window opens up. Click on Switch to Decimal Degrees.  

4. Enter the coordinates you wrote down from Google Earth for the west, north, 

south, and east sides. Include the negative signs that appear in the coordinates. 

See the Location Coordinates Section if you do not know the coordinates.  

5. Click on Add Area and click OK. The area for your plot is now set.  

Next choose what you want to download. 

1. Click Modify Data Request.  

2. Put a check next to each item you want to download. Set the formats to GeoTIFF, 

Zip, and HTML for any items you select.  

Below, some of the useful choices are listed. 

NATIONAL ELEVATION DATASET (NED) 

These are the USGS DEMs. All resolutions are listed but not necessarily available for 

your area. Use the highest resolution available for your area. Most areas do not have a 1/9 

Arc Second (1 meter) resolution DEM. You can select more then one here if you want. 

For more about resolutions see the DEM Overview. 

 

http://seamless.usgs.gov/
http://seamless.usgs.gov/


24K DRG (DIGITAL RASTER GRAPHICS) 

This is a topographic map. It contains location markings for buildings, trees, swamp 

areas, etc. and is useful to verify elevation data. 24k is the highest resolution version. 

 

DOQQ 1.0M (DIGITAL ORTHOIMAGERY QUARTER QUADRANGLES) 

This is a black and white (or in some cases infrared color) satellite image taken in the 

90's. 

 

ORTHOIMAGERY 

This is a high resolution color image. For the most part this image is only available in 

urban areas.  

 

When you are finished, click Save Changes & Return to Summery. 

The download screen appears with the items you checked. If an item doesn't show up 

then it is unavailable in your area. You can click Modify Data Request to go back to the 

list and make changes. 

To download each item, click on the download button next to it. A new window opens. It 

may take awhile for it to process your request. When it is finished it prompts you to save. 

Repeat this process for the other items you want to download. 



 

GeoComm 

GeoComm contains the same data as the USGS Seamless server but it is presented in a 

different way. Instead of entering in the coordinates for your location you download the 

tile your course is located in. The tiles are sorted by state, county and city. 

To get started you need to register for a free account on the GeoComm Site. Once you've 

done that you're ready to start looking for the DEM. If you know the town or city where 

your course is located try doing a Google search to find the county in which it resides. 

Another thing you can try is to gradually zoom out in Google Earth until it displays the 

counties. 

1. Open the GeoComm Site and select the state your course is located in.  

2. Select the county the course is located in.  

3. Select the first item on the list "Digital Elevation Models (DEM) - 24K".  

4. Select the city or town your course is near and click on the green download button 

to the right.  

5. Depending on your location you may have more then one resolution option to 

download. Download the highest resolution available. For more on resolutions see 

the DEM Overview.  

If your coordinates are off the screen when you load the DEM tile in 3DEM then you 

have the wrong tile and you'll need to go back to the GeoComm Site and try a different 

one. In some cases your course may reside on two or more DEM tiles. To open multiple 

files in 3DEM, select and hold down the CTRL key. 3DEM assembles all of the selected 

files together. 

http://data.geocomm.com/dem/demdownload.html
http://data.geocomm.com/dem/demdownload.html


 

Google Earth/Microsoft Virtual Earth 

Unfortunately both Google Earth and Microsoft Virtual Earth do not provide a way to 

save imagery at high resolution. This makes them more difficult to work with then the 

USGS. 

One solution is to use the Print Screen key. Doing this you'll either need to fit the entire 

plot on screen and have a low resolution image or stitch a bunch of screenshots together 

in a paint program. 

Instead, to save some work and still have a high resolution image, use an oversized 

Google or Microsoft Map in a webpage. Then use a browser plug-in to take a screenshot 

of the entire webpage. 

First you need to download and install the plug-in for your web browser: 

 Screengrab for Firefox.  

 iWebshot for Internet Explorer (no need to register, the free version is enough).  

Now you're ready to load the image.  

1. Download the Google Maps and Microsoft Virtual Earth HTML Files and unzip 

them to your hard drive.  

2. Right click on the desired webpage file, select "Open With" and choose Notepad. 

If Notepad is not on the list then select "Choose Program", select Notepad, and 

click OK.  

You'll see the HTML code for the page. 

1. Find the section that says "Edit the Coordinates for your Map Below". 

 
2. On the first line below change the coordinates to the latitude and longitude 

coordinates for the approximate center point of your plot. On the second and third 

lines change the coordinates to the latitude and longitude for northwest corner and 

southeast corner. See the Location Coordinates Section if you do not know the 

coordinates.  

3. Find the section that says "Edit the Pixel Size for your Map Below". This is where 

you set the map size. You can leave this unchanged for now but you may have to 

http://www.screengrab.org/
http://www.download.com/iWebshot-Free-Edition/3000-12777_4-10595399.html?tag=lst-1&cdlPid=10715422
http://www.zagerdesign.com/golf_design/files/tutorials/mapping/maps_html.zip


go back and adjust it if your image doesn't fit in the window. 

 
4. Save changes, close notepad, and open the file in your web browser.  

5. Use the browser scroll bars to move around the map and look for the markers. 

 
These mark the northwest and south east corners of the plot. If you do not see 

them –  

1. Close the browser and open the file in notepad again.  

2. Find the section that says "Edit the Pixel Size for your Map Below".  

3. Increase the number for width and height.  

6. Use the zoom control to zoom to the largest level where you still get and image. If 

zooming in, again check that you can still see the markers and if not adjust the 

map's size as in step 5.  

7. The image takes awhile to load even on a high speed connection. Once it is fully 

loaded and you have both markers in view, use the browser plug-in to save a 

screenshot of the entire map.  

1. In IE go to Tools > iWebshot.  

2. In Firefox right click anywhere in the window and go to Screengrab > 

Save > Complete Page/Frame.  

8. The plug-in opens and allows you to save the screenshot.  

9. Finally open the saved screen shot in a paint program and crop it so the corners of 

the image are at the points the markers point to. Now your image matches the 

coordinates of your plot exactly.  

10. Save it. To keep the file size down you may want to save it as a JPEG and delete 

the original image. 



 

Trimming and Saving the DEM in 3DEM 

A free program called 3DEM is used to trim the DEM if needed and save it to a different 

format. Before you begin visit the 3DEM Website to download and install it. 

1. Open 3DEM and go to File > Load Terrain Model  

2. Select the file type your DEM is in.  

o For DEMs downloaded from USGS Seamless select GeoTiff DEM.  

o For DEMs downloaded from GeoComm select USGS DEM.  

3. Go to Operation > Change Projection > Convert to UTM Projection.  

4. Select NAD27 and click OK.  

If your DEM does not have the exact coordinates of your plot you'll need to trim it. If you 

used the USGS Seamless Site and entered the exact coordinates skip to saving the DEM. 

1. Go to Operation > F8 Select Smaller Region.  

2. Move your mouse cursor until it is precisely at the NW coordinates that you wrote 

down earlier.  

3. Click and hold down your left mouse button.  

4. Drag downward to the right until you get to the SE coordinates.  

5. Release the left mouse button and hit Enter on your keyboard. The full DEM is 

replaced by the smaller area you selected.  

Now you need to save the DEM in a new format.  

1. Go to File > Save Terrain Matrix  

2. Select ASCII Text String and click OK.  

3. Give it a name and save it.  

4. Close 3DEM. 

http://www.visualizationsoftware.com/3dem.html


 

Creating the DXF Mesh with AccuTrans 3D 

AccuTrans 3D is used to create the DXF mesh from the files saved in 3DEM. Before you 

begin visit the AccuTrans 3D website to download and install it. 

3DEM saves a *.txt and *.hdr file with the name you gave it. If you can't see extensions–  

1. Open any folder in windows  

2. Go to Tools > Folder Options.  

3. Click on the View Tab and uncheck "Hide extensions for known file types".  

Now find the folder where you saved the files from 3DEM. 

1. Open the *.hdr file in notepad. Open any folder in windows.  

2. Find the line that says "number_of_columns" and make a note of the number. 

 
3. Close Notepad.  

4. Open AccuTrans 3D.  

5. Go to File > Open DEM As > ASCII to DEM (*.txt)  

http://www.micromouse.ca/


6. Find the *.txt file saved from 3DEM and open it. A dialog box opens. 

 
7. Verify SW corner and Row are selected.  

8. Under sample distance set X spacing and Y spacing to the resolution of your 

DEM in meters. For example if it is a 10 meter (1/3 arc second) DEM set the X 

and Y spacing to 10.  

9. Next to columns enter the number you wrote down from the *.hdr file.  

10. Click on the calculate rows button. This automatically calculates the number of 

rows based on the number of columns you enter.  

11. Click OK. The DEM opens with a color coded contour map.  

12. Go to Dem > Convert to 3D (less water).  

13. Keep the default values and select OK. A 3D view of the DEM is displayed. You 

can move it around by clicking the display and dragging it.  

14. Go to File > Save With Options. 

 
15. Under Save File Type chose DXF (*.dxf) and put a check in the check box to the 

left.  

16. Under Flags verify there is a check next to Point Cloud, Lines, and AutoCAD and 

Lightscape.  

17. Under Center Point put a check mark next to adjust and click the Calc button. 

This centers the mesh on your plot.  



18. Click on the DXF tab and verify Output As 3D Face is selected. 

 
19. Click Save, give it a name, and save it.  

20. Close AccuTrans 3D.  

The DXF file is now ready for import in CPG. 



 

DXF Tool 

First put the DXF file in the correct folder:  

WINDOWS XP: 

C:\Documents and Settings\All Users\Application 

Data\CustomPortal\Resources\DXF  

WINDOWS VISTA: C:\ProgramData\CustomPortal\Resources\DXF  

 

1. From the main menu go to Options > Game and set the units of measurement to 

match what your DEM uses. Use metric if the DEM resolution is in meters. You 

can change it back to your preferred units after the DXF mesh import is complete. 

2. Open up a new plot in CPG.  

3. Go to Tools > DXF. The dialog box above opens.  

4. Click on Open DXF.  

5. Open the DXF folder, find your DXF file, and click OK. The mesh is now 

displayed.  



6. Drag the corners of the plot to approximately fit the mesh. You can move the 

dialog box out of the way if needed by clicking on its top bar and dragging it. If 

you are not using a satellite image that is matched in size with your plot then this 

is close enough and you can skip to step 12.  

7. Right click on one of the corners of the plot, go to View, and select Zoom To.  

8. Click and hold the mouse button on the corner of the plot. While still holding the 

mouse button, move the view with the Q, A, and arrow keys until the corner of 

the mesh is centered on the screen. 

 
9. Move the corner point of the plot on top of the corner of the mesh and release the 

mouse button.  

10. Right click on the plot, go to View and select Zoom To.  

11. Repeat steps 7-10 with the other 3 corners of the plot. Your plot now matches the 

DXF mesh exactly.  

12. Under Meshes select your mesh and click Import Mesh.  

13. Importing takes as much as 10-15 minutes depending on your computer and the 

size of the mesh.  

14. When import is complete close the dialog box.  

If you go to Layers > Height you now see the elevations. You may have rough edges on 

the plot but this is easily fixed by moving the corners of the plot in. However do not do 

this yet if you have an image you want to use with the Blueprint Tool that is exactly the 

same size as the plot. 



 

Blueprint Tool 

These instructions assume your image matches your plot size exactly. For more on how 

to do this, see the Imagery Overview Section. 

First put any images you want to use in the correct folder:  

WINDOWS XP: 

C:\Documents and Settings\All Users\Application 

Data\CustomPortal\Resources\Textures\Blueprints 

WINDOWS VISTA: C:\ProgramData\CustomPortal\Resources\Textures\Blueprints 

 

1. Open up the plot you want to use the image on.  

2. If your not on the surface layer go to Layers > Surface.  

3. Go to Tools > Blueprint Tool. The dialog box above opens.  

4. Put a check next to enabled.  

5. Click on Change, open the Blueprints folder, and select your image.  

6. Verify that Lock Aspect Ratio is checked and drag one of the dimension sliders 

until the image approximately fits your plot size.  



7. Click OK.  

8. Right click on one of the corners of your plot, go to View and select Zoom To. 

Zoom out using the down arrow until the corner of the image comes into view.  

9. Go to Tools > Blueprint Tool.  

10. Click on the arrows next to the dimensions slider to fine tune the image size. Fit 

the image edge as close to the plot edge as you can.  

11. Click OK.  

This process is not perfect. You now need to fine tune it.  

1. Go to Layers > Height.  

2. Check over the plot and if the image needs adjusting go to Tools > Blueprint Tool 

and adjust the offset, dimensions or rotation as needed. The best way to do this is 

use a lake bed, stream, or other obvious land feature. Check these on opposite 

sides of the plot and run through each hole on your course.  

3. Once you have it lined up correctly, write down these settings so you can easily 

reset the image next time.  

If you have more then one image repeat this process for any other images. Once you have 

the settings for all the images you can adjust the plot corners to trim the jagged edges off. 

That's it, now you can start laying out your course. Good Luck! If you have any questions 

please post in the forum. 

http://www.customplaylive.com/forum/index.php
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